Login

 
Registration

If you are not registered:

Register Now

Contact

Please do not hesitate to contact us if you have any queries, or visit our website:

Visit our Website
www.node4.co.uk

Email our helpdesk
info@node4.co.uk
sales@node4.co.uk
support@node4.co.uk

Call us
General enquiries: 0845 123 2222
Support: 0845 123 2229
Fax: 0845 123 2221

N4Status

Node4 status page detailing information about incidents and planned maintenance:

http://www.n4status.co.uk

Knowledgebase
Cisco - ADSL to VDSL
Posted by Mark Hill on 14 June 2016 05:40 PM

How to convert a Cisco router over to VDSL from ADSL:

1. Disabled atm0 (conf t -> int atm0 -> shut)
2. Enable eth0 (conf t -> int eth0 -> no shut)
3. Configured the dialer (which was on atm0) to run on eth0.101 (This does not show until configured)

Your interfaces should look like the below:

(Show run int <Interface required>)

interface ATM0
no ip address
no ip route-cache
shutdown

interface Ethernet0
no ip address
no shutdown
no fair-queue

interface Ethernet0.101
encapsulation dot1Q 101
pppoe-client dial-pool-number 1
no shut

interface Dialer1
description *** Node4 TTB ADSL ***
ip address negotiated
ip flow ingress
ip flow egress
ip nat outside
ip virtual-reassembly in
encapsulation ppp
dialer pool 1
dialer-group 1
ppp authentication chap callin
ppp chap hostname xxxx@xxxxx
ppp chap password 0 xxxxxx
no cdp enable

To confirm its working:

Router# show controller VDSL 0
Controller VDSL 0 is UP

Daemon Status: Up

                              XTU-R (DS)   XTU-C (US)
Chip Vendor ID:        'BDCM'          'BDCM'
Chip Vendor Specific: 0x0000         0xA194
Chip Vendor Country: 0xB500        0xB500
Modem Vendor ID:     'CSCO'          'BDCM'
Modem Vendor Specific: 0x4602     0xA194
Modem Vendor Country: 0xB500     0xB500
Serial Number Near: FGL151222YQ  887VA-SE 15.1(2)T
Serial Number Far:
Modem Version Near: 15.1(2)T
Modem Version Far:   0xa194

Modem Status:        TC Sync (Showtime!)
DSL Config Mode:    AUTO
Trained Mode:         G.993.2 (VDSL2) Profile 12a
TC Mode:               PTM
Selftest Result:        0x00
DELT configuration: disabled
DELT state:            not running
Trellis:                    ON               ON
Line Attenuation:    0.0 dB         0.0 dB
Signal Attenuation: 0.0 dB         0.0 dB
Noise Margin:        39.8 dB       24.3 dB
Attainable Rate: 92444 kbits/s  27229 kbits/s
Actual Power:       14.5 dBm       -18.5 dBm
Per Band Status:           D1  D2      D3  U0  U1  U2   U3
Line Attenuation(dB):    3.5  7.5    N/A 1.9 6.7 7.9   N/A
Signal Attenuation(dB): 3.5  7.5    N/A 0.0 6.1 6.8   N/A
Noise Margin(dB):        39.6  39.8 N/A 24.5 24.1 24.5 N/A
Total FECS:                    0                  0
Total ES:                       0                  0
Total SES:                     0                  0
Total LOSS:                   0                  0
Total UAS:                    0                  0
Total LPRS:                   0                  0
Total LOFS:                   0                  0
Total LOLS:                   0                  0
Bit swap:                     0                  0

Full inits:                     1
Failed full inits:             0
Short inits:                   0
Failed short inits:           0

Firmware      Source       File Name (version)
--------        ------        -------------------
VDSL           embedded  VDSL_LINUX_DEV_01212008 (1)

Modem FW Version: 100608_1515-4.02L.03.A2pv6C030h.d22k
Modem PHY Version: A2pv6C030h.d22k

                         DS Channel1   DS Channel0    US Channel1    US Channel0
Speed (kbps):       0                 26941             0                   8127
Previous Speed:     0                 0                    0                   0
Reed-Solomon EC: 0                 0                    0                    0
CRC Errors:           0                 0                    0                   0
Header Errors:       0                 0                    0                   0
Interleave (ms):    0.00             0.00               0.00               0.00
Actual INP:           0.00             0.00              0.00                0.00

Training Log :              Stopped
Training Log Filename : flash:vdsllog.bin

You can also do:

Router# show ip interface brief

Any interface listed with OK? value "NO" does not have a valid configuration


Interface          IP-Address           OK?    Method    Status                      Protocol
ATM0              unassigned          YES     NVRAM    administratively down down
Dialer1          86.***.***.***   YES    IPCP       up                           up
Ethernet0       unassigned         YES     unset       up                          up
Ethernet0.101 unassigned         YES     unset      up                           up
FastEthernet    unassigned         YES     unset      up                           up

If there is no IP next to dialer1 there is an issue

Show int <Interface required>
Ethernet is up, line protocol is up (connected)
Hardware is <router or Nic>
MTU 1500 bytes, BW 10000 Kbit/sec, DLY 100 usec,
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation ARPA, loopback not set
Keepalive set (10 sec)
Full-duplex, 1Gb/s, media type is ****
input flow-control is on, output flow-control is off
Clock mode is auto
ARP type: ARPA, ARP Timeout 04:00:00
Last input never, output never, output hang never
Last clearing of "show interface" counters never
Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
Queueing strategy: fifo
Output queue: 0/40 (size/max)
5 minute input rate 7000 bits/sec, 8 packets/sec
5 minute output rate 10000 bits/sec, 11 packets/sec
L2 Switched: ucast: 0 pkt, 0 bytes - mcast: 0 pkt, 0 bytes
L3 in Switched: ucast: 0 pkt, 0 bytes - mcast: 0 pkt, 0 bytes mcast
L3 out Switched: ucast: 0 pkt, 0 bytes mcast: 0 pkt, 0 bytes
4495527 packets input, 488522378 bytes, 0 no buffer
Received 4460539 broadcasts (1153347 multicasts)

From the above make sure traffic passing as expected through all required interfaces (input rate, output rate, packets input and Received)

Finally ping 8.8.8.8

If you get a ping response and dialer1 has an IP assigned all changes have worked.

(0 vote(s))
Helpful
Not helpful

Comments (0)
Post a new comment
 
 
Full Name:
Email:
Comments: